os2 loader

Collecting list of kernel bugs
David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Postby David McKenna » Fri Feb 29, 2008 18:43

Pasha wrote:Create pls AltF2On.$$$ in root of boot disk. What file you see in screen?


I did this and boot still hangs at the 'boot-blob', but now the screen looks like:

-------------------------------------------------------------------------------------
OS/2




OS2DBCS.FNT_

Loading OS2KRNL (14.104a_SMP)






BootJFS. Product of Serenity Systems International. (c) Pavel Shtemenko
------------------------------------------------------------------------------------

There is a blinking cursor after 'OS2DBCS.FNT'.

dixie
Posts: 10
Joined: Thu Dec 14, 2006 10:24

Postby dixie » Sat Mar 01, 2008 00:23

Try to modify os2ldr.ini file to something like this:

Code: Select all

[config]
default=1
timeout=10

[kernel]
os2krnl=Default kernel,NODBCS

i.e. add NODBCS into your kernel string.

David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Postby David McKenna » Sat Mar 01, 2008 01:30

Dixie,

I added NODBCS as you describe to the os2ldr.ini file. The boot still hangs in the same place. Now it looks like:

-------------------------------------------------------------------------------------
OS/2




OS2DUMPMSG

Loading OS2KRNL (14.104a_SMP)






BootJFS. Product of Serenity Systems International. (c) Pavel Shtemenko
------------------------------------------------------------------------------------

User avatar
Pasha
Posts: 82
Joined: Fri Apr 21, 2006 14:17

Postby Pasha » Sat Mar 01, 2008 12:21


David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Postby David McKenna » Sat Mar 01, 2008 22:14

Pasha,

I tried this test os2ldr, but no change - I get the same hang.

User avatar
Pasha
Posts: 82
Joined: Fri Apr 21, 2006 14:17

Postby Pasha » Mon Mar 03, 2008 11:26

Now we do debug output for users, need wait. Can you try remove os2logo and config.sys. Where stop of boot?

David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Postby David McKenna » Tue Mar 04, 2008 01:37

Pasha,

I renamed os2logo and config.sys to os2logox and config.syx. With your test ACPI and your test os2ldr, with NODBCS in os2ldr.ini, the computer hangs exactly like it did before - at the OS/2 'boot-blob' with OS2DUMPMSG showing.

User avatar
Pasha
Posts: 82
Joined: Fri Apr 21, 2006 14:17

Postby Pasha » Tue Mar 04, 2008 23:00


David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Postby David McKenna » Wed Mar 05, 2008 19:14

Pasha,

I still get the same hang with this new os2ldr. I uploaded a picture of the hang screen as you requested: davesos2ldr.jpg.

dixie
Posts: 10
Joined: Thu Dec 14, 2006 10:24

Postby dixie » Thu Mar 06, 2008 00:11

David McKenna wrote:I still get the same hang with this new os2ldr. I uploaded a picture of the hang screen as you requested: davesos2ldr.jpg.

Sorry David, we forgot about main thing ;)
Add dbport=0 key into config section of os2ldr.ini and try again:

Code: Select all

[config]
default=1
timeout=4
dbflags=0x11
dbport=0

David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Postby David McKenna » Thu Mar 06, 2008 19:32

Dixie,

Yes, that made a difference :-) I have uploaded a photo of the hang screen 'davesos2ldr2.jpg'.

User avatar
Pasha
Posts: 82
Joined: Fri Apr 21, 2006 14:17

Re: os2 loader

Postby Pasha » Sat Mar 22, 2008 01:45


David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Re: os2 loader

Postby David McKenna » Sat Mar 22, 2008 05:54

Pasha,

I tried this new os2ldr and I'm sorry to say it still hangs at boot. I have uploaded a photo of the screen 'davesos2ldr3.jpg' I used this new os2ldr, your 'test' acpi.psd from 28022008 and the os2ldr.ini suggested by dixie...

David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Re: os2 loader

Postby David McKenna » Mon Jun 30, 2008 01:20

Just an FYI... I have tried the new version (0.2) of OS2LDR and I have the identical problem I had with the previous one. Boot hangs with the JFS copywrite notice at the bottom of the screen....

Dave McKenna

User avatar
Pasha
Posts: 82
Joined: Fri Apr 21, 2006 14:17

Re: os2 loader

Postby Pasha » Wed Jul 02, 2008 20:55

David McKenna wrote:Just an FYI... I have tried the new version (0.2) of OS2LDR and I have the identical problem I had with the previous one. Boot hangs with the JFS copywrite notice at the bottom of the screen....


What is a kernel version you are use?

David McKenna
Posts: 60
Joined: Fri Jul 07, 2006 00:19

Re: os2 loader

Postby David McKenna » Thu Jul 03, 2008 00:13

Pasha,

Kernel is 14.104a_SMP... same as before. This on eCS 2.0 RC4 with ACPI 3.09.

Regards,

Dave McKenna

Alan Beagley
Posts: 67
Joined: Wed Jul 26, 2006 02:06

Re: os2 loader

Postby Alan Beagley » Thu Jul 10, 2008 01:32

I've just tried this new loader on my eCS2.0RC5 setup with ACPI 3.09 and Kernel 14.104a_SMP. I get the BootJFS copyright notice followed by:
OS/2 !! SYS03146
OS/2 !! SYS02027

Same whether I use the original os2ldr.ini or the modified one suggested previously.

Hardware is Asus M2N-SLI Deluxe -- nVidia nForce 570 Ultra
Alan

User avatar
Pasha
Posts: 82
Joined: Fri Apr 21, 2006 14:17

Re: os2 loader

Postby Pasha » Mon Jul 14, 2008 02:45

Alan Beagley wrote:I've just tried this new loader on my eCS2.0RC5 setup with ACPI 3.09 and Kernel 14.104a_SMP. I get the BootJFS copyright notice followed by:
OS/2 !! SYS03146
OS/2 !! SYS02027

Same whether I use the original os2ldr.ini or the modified one suggested previously.

Hardware is Asus M2N-SLI Deluxe -- nVidia nForce 570 Ultra


You have absent file, check, if os2krnl w/o ext (mean os2krnl.dbg) - "." must be absent.

Right

os2krnl = My load kernel

Wrong

os2krnl. = My load kernel


Return to “Kernel”

Who is online

Users browsing this forum: No registered users and 0 guests

cron