What's wrong with general LVM

ALVM (LVM = Logical volume manager) for eComStation
User avatar
Papa Karlo
Posts: 36
Joined: Tue Jun 28, 2005 16:52

What's wrong with general LVM

Postby Papa Karlo » Mon Jul 31, 2006 11:45

For example, if you have hard disk with/after Windows XP or even Windows XP installer(with option install on all disk and fast format to NTFS)
Then, with eCS installation or pure lvm you will see

Image

1
run LVM and see message about corrupt partition table, press Enter

Image
2
message for USB-drive, indeed it should be drive not ready message, press Enter
Image
3
Quite reasonable message, but indeed system can't use disk 1 as well.
Press Enter
Image
4
Press F5
Image
5
Press Tab
Image
6
Press Enter
Image
7
Look up and bottom, press Tab
Image
8
press F3
Image
9
Select "Save changes", press Enter
Image
10
Look at last LVM's message, leave LVM

And now, run LVM again. Nothing is changed, goto to picture number 1

Warpforever

WinXP and OS/2 LVM install

Postby Warpforever » Tue Aug 01, 2006 17:52

This problem can be easy solved if you manage the partitions only with LVM, let LVM create the winxp install partition and all be fine :D

LVM however should work with the disk even if its created with win tools, this needs to be fixed among other bugs. Would be nice if you could use the trak system from netlabs if the project goes this way... good luck !

User avatar
Papa Karlo
Posts: 36
Joined: Tue Jun 28, 2005 16:52

Postby Papa Karlo » Mon Aug 07, 2006 10:50

Some info about problems with booting from USB and/or non-first hdd:

* LVM can't made bootable partition on USB disk, ALVM - can
o one of the reason is that DosDevIOCtl(FileHandle,IOCTL_OEMHLP,OEMHLP_QUERYDISKINFO,..) return zeros for USB disks (bug in usbd drivers ?)

* eCS's installer can't install system on USB drive - it even doesn't show any usb drives with "show all volumes and partitions" option (This is not mini-lvm window) May be this is result of OEMHLP_QUERYDISKINFO bug

* kernel want not to boot from second (non first) disk in system. This is definitly some extra checks in kernel and it can be easily fixed
* if there is only one disk in system and this disk is usb than boot starts, shows logo and than hangup with "the system can't operate your hard disk" message. This is possibly os2dasd and usbd - related

* some extra bug with genegal LVM - it can't add to bootmanager (on hard disk) botable volume from USB drive (the reason will be found in ALVM)


Return to “ALVM for eComStation”

Who is online

Users browsing this forum: No registered users and 1 guest

cron