eSchemes 1.37 20061112

Under the impression of eSchemes
cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

eSchemes 1.37 20061112

Postby cris » Thu Apr 12, 2007 18:18

Hi,
I have been testing again eSchemes (after upgrading it to the latest release to try to solve a problem with eSchemes Deluxe).

I am experiencing mixed results, and I would like to know exactly what to expect so that I can test it thoroughly.

I am testing on eCS 1.2MR.

After applying a scheme (I tried with EcoToys) I have the following:

- colors are applied correctly
- window titlebar buttons (minimize, maximize, etc) are NOT applied
- windows controls (checkbox, etc) are NOT applied
- title bar gradients are NOT applied
- other titlebar settings (color, inactive color, 3D text, etc) are applied
- cursors are applied
- sounds are applied
- background bitmap is applied

Of those NOT applied, which is expected (not yet implemented) and which is NOT expected?

I am particularly surprised by the windows titlebar buttons not applying, since in the first versions of eSchemes they did apply. The same (IIRC) is true for titlebar gradients.

I have a directory called $$$ES$$$ in the %TEMP% directory, that contains the various bitmaps and resources that should have been applied. It also contains the PMMRGRES.DLL file, which should be modified (I think) to incorporate the new resources... but it is NOT modified (I compared it with the one in \os2\dll).

Any hints? Is it all like it should be?

Bye
Cris

User avatar
Gabriele
Posts: 98
Joined: Tue Mar 21, 2006 21:47

Re: eSchemes 1.37 20061112

Postby Gabriele » Mon Apr 16, 2007 17:14

cris wrote:Hi,
I have been testing again eSchemes (after upgrading it to the latest release to try to solve a problem with eSchemes Deluxe).

I am experiencing mixed results, and I would like to know exactly what to expect so that I can test it thoroughly.

I am testing on eCS 1.2MR.

After applying a scheme (I tried with EcoToys) I have the following:

- colors are applied correctly
- window titlebar buttons (minimize, maximize, etc) are NOT applied
- windows controls (checkbox, etc) are NOT applied
- title bar gradients are NOT applied
- other titlebar settings (color, inactive color, 3D text, etc) are applied
- cursors are applied
- sounds are applied
- background bitmap is applied

Of those NOT applied, which is expected (not yet implemented) and which is NOT expected?

I am particularly surprised by the windows titlebar buttons not applying, since in the first versions of eSchemes they did apply. The same (IIRC) is true for titlebar gradients.

I have a directory called $$$ES$$$ in the %TEMP% directory, that contains the various bitmaps and resources that should have been applied. It also contains the PMMRGRES.DLL file, which should be modified (I think) to incorporate the new resources... but it is NOT modified (I compared it with the one in \os2\dll).

Any hints? Is it all like it should be?

Bye
Cris


Hi Cris:


I am testing on eCS2.0 beta 3

Scheme: Forest

- colors are applied correctly
- window titlebar buttons (minimize, maximize, etc) ARE applied
- windows controls (checkbox, etc) are NOT applied
- title bar gradients ARE applied (but maybe they come from estyler??)
- other titlebar settings (color, inactive color, 3D text, etc) are applied
- background bitmap is applied

$$$ES$$$ is here too.

Bye
Gabriele

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Mon Apr 16, 2007 17:26

Please, wait for newer version. We are trying to solve most of problems with apply scheme in oncoming release.
wbr,
Yuri

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Tue Apr 17, 2007 10:32

Thank you Yuri, I'll wait for the new release.
Any hints about the date?

Bye
Cris

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Tue Apr 17, 2007 10:56

Well. Hard to say but I have a plan to start release alphas (to test small parts of apply process) starting from this weelend.
wbr,

Yuri


Return to “WPS: eSchemes”

Who is online

Users browsing this forum: No registered users and 3 guests

cron