eSchemes Deluxe 20070409

Under the impression of eSchemes
cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

eSchemes Deluxe 20070409

Postby cris » Wed Apr 11, 2007 13:12

Hi Yuri,
I have been investigating a little bit more on the subject.

At home I can trigger the crash (trap in SOM.DLL at 0001:00015677) in various situations.

So I thought to test on a copy of eCS 1.2R under VPC that I have at work. It is configured quite differently with respect to my home copy, but I have the very same crash (trap in SOM.DLL, same location).

One thing they have in common (and that I was suspecting about) is WPSWizard with some experimental upgrades that allow bigger icons and PNG icons. So I disabled completely WPSWizard by renaming the installation directory. For added security I unregistered the classes related to the experimental features, and removed the related class replacements.
The result unfortunately is that I still have the crash.

But here at work I have a slightly more definite behaviour: I usually can open mostly every folder, and even enable the preview window without problems; but one way of SURELY crashing the WPS (it happens EVERY time) is to open the "Drives" folder. It opens, starts populating, then hangs with the words "Collecting objects..." in the status bar. POPUPLOG.OS2 shows the usual trap in SOM.DLL, but the other logs are apparently clean.

With respect to the previous versions I have to say that now the crash is less serious: I cannot restart the WPS, but I can cleanly recover by rebooting through CADH. Previously I had a complete lock.

One small additional tip: the TGA and TIF codecs write their log in the root instead of using the LOGFILES environment variable.

Am I the only one testing eSchemes Deluxe? Or I am the only one having problems?

Bye
Cris

User avatar
Eugene Gorbunoff
Site Admin
Posts: 685
Joined: Sat Apr 09, 2005 11:18
Location: St.Petersburg, Russia

Postby Eugene Gorbunoff » Wed Apr 11, 2007 13:17

btw, did you upgraded eSchemes Deluxe?
http://en.ecomstation.ru/apecs.php?action=item&id=996

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

eSchemes Deluxe 20070409

Postby cris » Wed Apr 11, 2007 14:51

Hi Eugene,
yes, I am using the latest eSchemes Deluxe available (eSchemes Deluxe 3.5 alpha 3)

Bye
Cris

User avatar
Eugene Gorbunoff
Site Admin
Posts: 685
Joined: Sat Apr 09, 2005 11:18
Location: St.Petersburg, Russia

Postby Eugene Gorbunoff » Wed Apr 11, 2007 14:55

How to compensate your patience? Please download Piano Launchpad from eSchemes Deluxe homepage.

OK.. traps in SOM.. I had this on one PC.. I don't remember how I fixed this..

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Wed Apr 11, 2007 16:20

Eugene Gorbunoff wrote:How to compensate your patience? Please download Piano Launchpad from eSchemes Deluxe homepage.


Wow, did not notice this one previously! :-) Thankyou!
I am downloading it now, and will try it ASAP! (Have to remove BubblePad before...)

Eugene Gorbunoff wrote:OK.. traps in SOM.. I had this on one PC.. I don't remember how I fixed this..


Please please please, try to remember this! I want my WPS back :-)
On which OS are you trying/using eSchemes? eCS 1.2? eCS 1.2MR? eCS 2.0 beta?

Thankyou!

Bye
Cris

User avatar
Eugene Gorbunoff
Site Admin
Posts: 685
Joined: Sat Apr 09, 2005 11:18
Location: St.Petersburg, Russia

Postby Eugene Gorbunoff » Wed Apr 11, 2007 17:19

it was eCS 1.2.. try deinstall eSchemes Deluxe, eSchemes..
check that no files from this packages.. then install Deluxe.

* eCS 2.0 beta 4 - eSchemes + eSchemes Deluxe work fine here.
* eCS 2.0 beta 3 - ignore it. eSchemes doesn't work

User avatar
Eugene Gorbunoff
Site Admin
Posts: 685
Joined: Sat Apr 09, 2005 11:18
Location: St.Petersburg, Russia

Postby Eugene Gorbunoff » Wed Apr 11, 2007 21:16

yee.. I start to remember.. you are using new eSchemes Deluxe and old eSchemes. Do you? If update eSchemes then traps in SOM.DLL disappear..

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Thu Apr 12, 2007 10:48

Thankyou Eugene,
I'm going to try it now here at work.
At home BTW I don't have eSchemes (not deluxe) installed, but I'm experiencing even more crashes than what I'm seeing at work.

Oh, I was almost forgetting: Piano Launchpad is GREAT! ;)

Bye
Cris

User avatar
Eugene Gorbunoff
Site Admin
Posts: 685
Joined: Sat Apr 09, 2005 11:18
Location: St.Petersburg, Russia

Postby Eugene Gorbunoff » Thu Apr 12, 2007 11:15

Piano launchpad: activate Auto-hide feature

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Thu Apr 12, 2007 13:50

Hi Eugene,
I have seen the auto-hide feature. It is cool! But... why you say I should activate it? Am I missing something?

Back to the crash problem: I have installed the latest eSchemes (not deluxe), and I was still having the crash.
I have done extensive testing: I am only crashing when I open the drives folder... everything else goes well.
So I began to suspect the WPDrive2 class, that IIRC is present in eCS 1.2MR bu not in plain eCS 1.2. WPDrive2 replaces WPDrives to be able (IIRC) to use something else instead of the JAVA LVMGUI when choosing "Manage volumes..." from the context menu of that folder.
I disabled WPDrive2 by renaming the DLL and rebooted.
Well... IT DOES NOT CRASH ANYMORE!!!!!

I think this should be reported to Serenity to fix the DLL. Also you should put a warning in the readme, and maybe even put a workaround in the WPI install script (e.g. disable WPDrive2, warning the user of the change).

Now let's see if this fixes the situation at home too...

The main differences from this installation here at work and my main installation at home are:

- full xwp installation at home vs. ewp installation at work
- no eSchemes (not deluxe) at home vs. eSchemes at work

I'll let you know if I can fix my home installation too.

Hope this helps!

Bye
Cris

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Thu Apr 12, 2007 16:39

Well, disabling WPDirve2 did not suffice at home...
I will try to find if there other conflicting DLLs (I have several WPS extensions at home).
BTW, if the conflict is with more than one DLL, it may be wise to check if the problem is in eSchemes Deluxe rather than in other DLLs... it could be a problem in the way you are subclassing or something like it... I don't really know SOM programming, so don't take my words too seriously.

Bye
Cris

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Thu Apr 12, 2007 17:30

Great work, Cris.

It seems I'll need to include tool into installation procedure to show tree of registered WPS classes. I'll check WPDrive2 class. After we can continue search for real problem (is it eSchemes Deluxe problem or WPDrive2 problem).

Thank you for your support and help.
wbr,
Yuri

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Thu Apr 12, 2007 17:52

prokushev wrote:Great work, Cris.


Thank you Yuri! :-)

prokushev wrote:It seems I'll need to include tool into installation procedure to show tree of registered WPS classes.


Yes, it would be of great help.
At home I can do it because I have a full XWP installation, but here at work I only have eWP, so I have no tool to show the tree of installed classes.
Moreover the XWP tool does not let you export the tree to a text file, so it is difficult to show it to someone else.

prokushev wrote:I'll check WPDrive2 class. After we can continue search for real problem (is it eSchemes Deluxe problem or WPDrive2 problem).

Thank you for your support and help.


Thanks to you too!

Bye
Cris

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Fri Apr 13, 2007 04:30

Heh. I reproduced WPS freeze with WPDrive2 class. Now will search where the problem.
wbr,

Yuri

User avatar
Gabriele
Posts: 98
Joined: Tue Mar 21, 2006 21:47

Postby Gabriele » Mon Apr 16, 2007 17:02

Eugene Gorbunoff wrote:yee.. I start to remember.. you are using new eSchemes Deluxe and old eSchemes. Do you? If update eSchemes then traps in SOM.DLL disappear..


Hi Eugene, I installed eSchemes-Deluxe-3-5-alpha3.ZIP and then d-3-5-a4.ZIP on eCS 2.0 beta 3. As some crashes happened here too, I tried to update eSChemes but the latest I find is eSchemes-20061112.wpi, that seems a bit old.

User avatar
Gabriele
Posts: 98
Joined: Tue Mar 21, 2006 21:47

Postby Gabriele » Mon Apr 16, 2007 17:07

Eugene Gorbunoff wrote:Piano launchpad: activate Auto-hide feature


What's the way to have it back after auto-hiding? Using the Screen Border Object function of XWP?

User avatar
Eugene Gorbunoff
Site Admin
Posts: 685
Joined: Sat Apr 09, 2005 11:18
Location: St.Petersburg, Russia

Postby Eugene Gorbunoff » Mon Apr 16, 2007 17:22

Properties of Launchpad -> switch between sub-pages

User avatar
Gabriele
Posts: 98
Joined: Tue Mar 21, 2006 21:47

Postby Gabriele » Mon Apr 16, 2007 17:26

but what should I do? Move the mouse pointer over the hidden launchpad area?

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Mon Apr 16, 2007 17:29

Gabriele wrote:
Eugene Gorbunoff wrote:yee.. I start to remember.. you are using new eSchemes Deluxe and old eSchemes. Do you? If update eSchemes then traps in SOM.DLL disappear..


Hi Eugene, I installed eSchemes-Deluxe-3-5-alpha3.ZIP and then d-3-5-a4.ZIP on eCS 2.0 beta 3. As some crashes happened here too, I tried to update eSChemes but the latest I find is eSchemes-20061112.wpi, that seems a bit old.


Can you tell more about crashes? Freeze on WPDrive2 class was fixed in a4 release. If problems still here please check wpfldrex.dll date and time to be same as in installation archive.
wbr,

Yuri

User avatar
Gabriele
Posts: 98
Joined: Tue Mar 21, 2006 21:47

Postby Gabriele » Mon Apr 16, 2007 17:49

prokushev wrote:
Gabriele wrote:
Eugene Gorbunoff wrote:yee.. I start to remember.. you are using new eSchemes Deluxe and old eSchemes. Do you? If update eSchemes then traps in SOM.DLL disappear..


Hi Eugene, I installed eSchemes-Deluxe-3-5-alpha3.ZIP and then d-3-5-a4.ZIP on eCS 2.0 beta 3. As some crashes happened here too, I tried to update eSChemes but the latest I find is eSchemes-20061112.wpi, that seems a bit old.


Can you tell more about crashes?


No :-) The Desktop failed to populate. I disabled all XWP functions, then reactive them one by one, and now it works again (with all the functions enabled as before...)
But desktop restart always fails and sometimes WPS freezes. I'll try to experiment more as soon as I'm ready for a reboot :-)

prokushev wrote:Freeze on WPDrive2 class was fixed in a4 release. If problems still here please check wpfldrex.dll date and time to be same as in installation archive.


It's the same: but I never had crashes in SOM.DLL, just WPS freezing.


Return to “WPS: eSchemes”

Who is online

Users browsing this forum: No registered users and 1 guest

cron