eSchemes Deluxe 20070307

Under the impression of eSchemes
cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

eSchemes Deluxe 20070307

Postby cris » Thu Mar 08, 2007 13:02

Hi,
I have just downloaded and installed eSchemes Deluxe 20070307.
I am experiencing frequent WPS crashes. POPUPLOG.OS2 report access violations in SOM.DLL (I am using eCS 1.2MR).

I have put here some infos that may be useful in diagnosing the problem:

http://guadagnino.i-ndex.net/2610/

Hope his helps...

Bye
Cris

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Mon Mar 12, 2007 18:17

Hi, Cris!

I don't see nothing bad in logs (except populog.os2, of course). Can you send additional info? I need:

1. Tree of WPFolder and it's replacements (Full tree of WPS classes from WPFolder)
2. More info about situation then WPS crashes. During navigation, during folder opening, during image preview, etc.

Thank you for your support.
wbr,
Yuri

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Thu Mar 15, 2007 17:50

Hi Yuri!

prokushev wrote:Hi, Cris!

I don't see nothing bad in logs (except populog.os2, of course). Can you send additional info? I need:

1. Tree of WPFolder and it's replacements (Full tree of WPS classes from WPFolder)


How do I do this? I don't see a way to export the tree to a text file.
If I can fit all in a screenshot I'll do it this evening and I will send it to you ASAP.

prokushev wrote:2. More info about situation then WPS crashes. During navigation, during folder opening, during image preview, etc.

Thank you for your support.


I have random crashes, usually when opening a folder (even if it doesn't show the preview). It usually says "Populating..." in the status bar.

I have downloaded and installed the new beta (20070313). I installed it but the system could not load the WPFolderEx class. After investigating a little, I discovered WPFolderEx depends on the ECOLANGE library which is NOT included in the package.
Fortunately I had the library from the USBDock package. I put the DLL in the libpath and rebooted: now the class was loaded correctly, but shortly thereafter I had another crash like those I had with the previous release :-(

Hope this helps...
Bye

Cris

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Thu Mar 15, 2007 20:36

Ok. ecolange and nls file added to archive (sorry) and hangs reproduces (on my system only in Drives folder) but solution not found yet.
wbr,

Yuri

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Fri Mar 16, 2007 15:53

Hi Yuri,
if it can be of any help, version 3.1 did not produce hangs here.

Another thing that may help you: when the WPS hangs I can't restart it. Even using the "forced kill" (kill -9) on pmshell.exe isn't effective. I have to reboot to regain access to the WPS.

Last bit of information: the problem is in WPFolderEx. If I don't load WPFolderEx (like when I didn't have ECOLANGE.DLL in the libpath) everything works well.

Hope this helps...
Bye

Cris

prokushev
Posts: 56
Joined: Wed Mar 22, 2006 19:38
Contact:

Postby prokushev » Sat Mar 17, 2007 06:53

Hi Cris.

I have some idea about where the problem. Can you install specialized version of WPFolderEx to test this issue?
wbr,

Yuri

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Mon Mar 19, 2007 18:58

Sure. Just send it my way and I'll test it as soon as I can.

Thankyou!
Bye

Cris

cris
Posts: 111
Joined: Thu Aug 24, 2006 18:11
Contact:

Postby cris » Wed Mar 21, 2007 16:26

Hi Yuri,
I installed the 3.4 alpha release, but still no joy.
This time I could open several folders without problem, but as soon as I opened a folder containing PDF files (no preview active) the WPS crashed.
POPUPLOG.OS2 cantained the usual trap in SOM.DLL (see my past logs), but I saw nothing bad in the other logs (deluxe.log, gifio.log, jpegio.log).

If you have a special release for me, please send it.

Bye
Cris


Return to “WPS: eSchemes”

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron