Search found 32 matches

Go to advanced search

by mikeforester
Sun May 31, 2009 13:37
Forum: Panorama videodriver
Topic: Write Combine fails
Replies: 2
Views: 4211

Re: Write Combine fails

Thanks, but that doesn't exactly answer my question. BIOS updates are necessary to support some motherboard utilities, and might be required for, e.g., Windows 7. I'm already looking at replacing assorted old hardware that works in OS/2 but that Win7 won't support.
by mikeforester
Wed May 20, 2009 01:40
Forum: Panorama videodriver
Topic: Write Combine fails
Replies: 2
Views: 4211

Write Combine fails

I have an Asus P5Q motherboard and ATI HD3650 video card on a 22" DVI monitor. Panorama's been working fine -- until Asus released a couple of new BIOS versions this year. Now Write Combine fails. log started at 19.5.2009 3:34:58 Profile setting for Shadow...ENABLED VBE VRAM size (rounded up):1...
by mikeforester
Wed Feb 27, 2008 10:50
Forum: Perfect eComStation / Будущая идеальная eCS
Topic: Perfect eComStation -- Must have Flash 8/9
Replies: 9
Views: 10578

There is a Linux program called nspluginwrapper that allows native 32-bit Linux plugins, like Flash, to work on 64-bit Linux. I'm not aware of any wrappers that allow the Windows version to be used. If I remember the story right, the reason Innotek never released Flash 7 for OS/2 had less to do with...
by mikeforester
Mon Feb 25, 2008 05:41
Forum: Perfect eComStation / Будущая идеальная eCS
Topic: Perfect eComStation -- Must have Flash 8/9
Replies: 9
Views: 10578

Perfect eComStation -- Must have Flash 8/9

I installed RC4 the other day and it went quite well, but it installs Flash 5. That's just useless; I hate to think what a new user would think the first time he fired up Firefox and the vast majority of websites that use Flash don't work. Ideally this would be a native, stable version of Flash that...
by mikeforester
Thu Oct 11, 2007 07:28
Forum: ACPI for eComStation
Topic: Anyone have trouble with VDMs and high IRQs?
Replies: 0
Views: 5067

Anyone have trouble with VDMs and high IRQs?

Ever since ACPI 3.xx came out and enabled high IRQs on nVidia, I haven't been able to start VDM sessions. Has anyone else had this problem? For background, see http://svn.netlabs.org/acpi/ticket/59 . Pasha's last best guess is that some DOS driver or DOS setting can't work with high IRQs. I agree, b...
by mikeforester
Thu Sep 27, 2007 01:25
Forum: Panorama videodriver
Topic: WarpOverlay and Panorama
Replies: 2
Views: 5743

I just tried warpoverlay-20051025.zip. Like Gabriele, I also have an ATI X800. WarpOverlay loads (the PCI ID is in the supported chipsets list), but it doesn't actually work. With WVGUI, I just get a black window (or black screen). DP.EXE thinks it's running, but there's nothing on screen. Valery's ...
by mikeforester
Wed Sep 19, 2007 19:59
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

One further note on this, in case someone needs it.

I discovered I have two low IRQs which are never shared and which I'm not using: IRQ12 (reserved for PS/2 mouse) and IRQ15 (reserved for secondary IDE channel). These work fine as REMAP targets, without having to change any BIOS settings.
by mikeforester
Tue Sep 18, 2007 14:58
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

Eugene Gorbunoff wrote:(target IRQ needs to be reserved in the BIOS)

That's fine. To be slightly more precise, you could say "target IRQ might need to be reserved in the BIOS." On my system, IRQ 5 is almost always free, while all the built-in and add-on PCI devices always want to use IRQs 10 & 11.
by mikeforester
Tue Sep 18, 2007 08:19
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

At nvidia you change high IRQ via ACPI.CFG keyword LINK These problems have been solved in 3.02, using REMAP instead of LINK, per nickk's ticket on netlabs. (Which, heh, is where I started this thread.) Eugene: You should remove SYM8XX.ADD from acpi-smp-drv.doc. Better, maybe, would be to start a l...
by mikeforester
Thu Sep 06, 2007 03:10
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

Re: ACPI 3.00, nVidia high IRQs vs. old drivers

Alan Beagley wrote:Wow! That was a quick reply. What parameters are you using on the ACPI.PSD line?

Heh. I just answered that too. ;)
by mikeforester
Thu Sep 06, 2007 03:08
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

Pasha, One other note. Normally I use just this in config.sys: PSD=ACPI.PSD /SMP /APIC I added the /TMR switch and it doesn't change the weird behavior of PCI0. Now in AcpiManger its name shows as "ò^G". /ALS doesn't "lock up" the system as I said earlier. Rather, it just hangs at the os2logo s...
by mikeforester
Thu Sep 06, 2007 03:03
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

Re: ACPI 3.00, nVidia high IRQs vs. old drivers

Mike, please remind me exactly what motherboard you have. I know I saw a mention that it's an nForce4, but which of the many? My Asus A8N-E works fine with ACPI 2.22 but stops at the boot screen with ACPI 3.0x if SMP is enabled -- happened when I tried to upgrade my RC1 setup to 3.0 and also when I...
by mikeforester
Thu Sep 06, 2007 02:28
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

At nvidia you change high IRQ via ACPI.CFG keyword LINK Thanks, Pasha, I had been meaning to try that. So now I have. It doesn't seem to change anything. After much head-scratching, I decided these two ACPI names are the SCSI and sound card. Under ACPI 2.22: +*APC2 T:[Device] HID:[PNP0C0F] UID:[21]...
by mikeforester
Wed Aug 15, 2007 23:15
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

Q1: I am developing a driver. How to create ACPI compatible driver? A1: Main rules: * don't set own restrictions to high IRQs > IRQ15 * read information about IRQ from PCI Config Space or from acpi.psd How to create driver ready for SMP and APIC mode? * Use DevEOI helper only, DON'T USE OUT 20h,20h...
by mikeforester
Wed Aug 15, 2007 18:49
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

look into ACPI-SMP-DRV.doc, sblive should work in APIC mode. It has worked fine in ACPI mode for me up till now. There's no code in the sblive driver to support IRQs higher than 15. I added some definitions for high IRQs to the version of the code that Steven Levine uploaded to svn on netlabs, but ...
by mikeforester
Wed Aug 15, 2007 18:10
Forum: ACPI for eComStation
Topic: ACPI 3.00, nVidia high IRQs vs. old drivers
Replies: 15
Views: 19194

ACPI 3.00, nVidia high IRQs vs. old drivers

I finally discovered ACPI 3.00 and installed it. It's nice to see all the high IRQs. Only problem is, old drivers (SBlive, SYM8XX.ADD) won't load with their new high IRQs. They're both physically on IRQ 11, but with the new ACPI they're mapped to 17 and 18, respectively. The drivers can't find the h...
by mikeforester
Sat Jun 02, 2007 05:46
Forum: ACPI for eComStation
Topic: Reboot problem solved
Replies: 3
Views: 7081

Re: Reboot problem solved

Since I installed eCS 2.0 beta 4 on this Athlon64 X2 system (NVidia chipset), reboot stopped working: the pc hanged just before video BIOS with a blinking cursor. /R parameter did not help. With version 2.22, problem is solved! Unfortunately, it only reboots sometimes for me. It seems like the long...
by mikeforester
Sat Jun 02, 2007 05:22
Forum: ACPI for eComStation
Topic: ACPI success but no APIC mode on Intel D975XBX2
Replies: 5
Views: 10595

Re: ACPI success but no APIC mode on Intel D975XBX2

I've tried /SMP /R /APIC /NOD /CD as well as removing the Connectix VPC driver from config.sys (the one that says it's disabling APIC mode as it loads!). Trevor, There's a switch for that: DEVICE=C:\VirtualPC\vpcapp.sys /apic will cause VPC to use the hardware APIC for high-res timing. I don't thin...
by mikeforester
Sun Apr 22, 2007 07:44
Forum: ACPI for eComStation
Topic: PowerNow! for AMD-64
Replies: 8
Views: 14221

Re: PowerNow! for AMD-64

Let's discuss PowerNow! for AMD-64! Well, I don't really know anything about it, but my BIOS has support for it. (May be disabled, I'd have to look.) When I run powernow-k8.exe I get this: Error 110 opening POWER$ (POWER.SYS) AMD-64 PowerNow Control error:powernow-k8: BIOS error - no PSB I'...
by mikeforester
Sun Apr 22, 2007 07:39
Forum: ACPI for eComStation
Topic: Enabling APIC mode
Replies: 4
Views: 8218

I installed SMP kernel (14.093a). Uptime.exe is working fine, so the battery widget. What's timer? [c:\ecs\bin]tmrtest.exe rc=0 Resolution:1193167 Elapsed 0 sec. Must be 0 Elapsed 2 sec. Must be 2 Elapsed 4 sec. Must be 4 Elapsed 6 sec. Must be 6 Elapsed 8 sec. Must be 8 This too seems fine, but I ...

Go to advanced search

cron